BXadmin:Solaris notes
group limit
This is very important on the mail servers, as procmail su's to the user, and if the user is in more than 13 groups (16 - private group - 2 PAG groups), then the AFS PAG gets forgotten, and mail delivery fails.
/etc/system
set ngroups_max=32
You can try to set this via mdb with echo ngroups_max/W 20 | mdb -kw, but the machine crashed shortly thereafter when I did this.
getconf NGROUPS_MAX will show you what the current value is.
Multipathing with IPv6
Because this isn't entirely obvious.
In this case, we have two interfaces, bge0 and bge1.
Host has addresses 128.118.200.78 and 2610:8:7800:14::32/64.
/etc/hosts
::1 localhost 127.0.0.1 localhost 128.118.200.78 inara.bx.psu.edu inara
/etc/hostname.bge0
inara group production up
/etc/hostname.bge1
group production up
/etc/hostname6.bge0
group production -failover up addif 2610:8:7800:14::32/64 up
/etc/hostname6.bge1
group production -failover up
Now for the trick to make this work if you're running autoconf on your network. If you don't do both of these, in.ndpd will configure an ADDRCONF interface after a failover/failback, resulting in two public IPv6 interfaces - the statically configured one and the autoconf'd one. No manner of ifconfig commands will remove that autoconf'd address.
/etc/inet/ndpd.conf
ifdefault StatelessAddrConf off
Then run:
$ svccfg -s routing/ndp:default setprop routing/stateless_addr_conf=false # makes in.ndpd run with -a $ svcadm restart ndp
Building Packages
For sparc, build on early. For intel you can use bigsky.
Building openafs as an example
- update /afs/bx.psu.edu/admin/pkgbuild/SPECS/openafs-1.6.spec
- use
/opt/bx/bin/pkgbuild -ba --pkgformat ds <specfile>
to build the new package - assuming you get a .pkg file, gzip it and move it to /afs/.bx.psu.edu/service/ftp/pub/software/solaris/<arch>/5.10
- use /opt/csw/bin/bldcat to update the catalog file
- release
- DO NOT simply upgrade all packages on river/jayne/simon. For an explanation of why, see https://wiki.bx.psu.edu/BXadmin%3ATodo
Since the package manager doesn't automatically update, you probably have to use pkgutil to upgrade BXopenafs by hand.
To test, simply copy the .pkg to whatever host you're going to test on and:
pkgrm BXopenafs pkgadd -d <pkgfile> BXopenafs